Home Contact

Accueil \

Actualité RC

ACTUALITÉ RC

PUBLICITÉ

West Coast R/C Works X12 servo & upper pod plates

Actualité
Actualité du 01/09/2017

West Coast R/C Works X12 servo & upper pod plates

The newest addition to West Coast R/C Works’ Black Carpet Edition line of parts are the servo mounting plates and short upper pod plate for the Xray X12 pan car. Starting with the servo mounting plates, these are designed to replaces the original parts and the bolt pattern of the plates ensure that the servo is mounted correctly on the chassis. The BCE plates are an addition to the already existing line of X12 servo mounting plates and the difference between the existing and the BCE version is that the new version has eleven shock mounting positions instead of only four on the original part. The additional shock mounting positions allow the shock to be moved further back on the chassis and it also allows use shocks from other manufacturers. The servo mounting plate is available with bold patterns to directly mount the Futaba 9650/9670, Futaba BLS671SV/ BLS671SVi or Sanwa SRG-HR/HS servos.

As for the short upper pod plate, the part was designed to further increase the adjustability of the shock position. Both the servo and shock plates are made from 3mm carbon fibre to withstand the hardest racing conditions and they will become available by mid of September.

Source: West Coast R/C Works [westcoastrcworks.us]

... Lire la suite sur Red RC - RC Car News

Source : Red RC - RC Car News Nos autres news du 01/09/2017
Visiteurs :

Total : 29853707
Depuis le : 01.06.2002



Localisation :
Locations of visitors to this page

POWERED BY

  • Spip
  • CSS
  • Xhtml
  • PHP
  • My SQL
  • Flux RSS de Gaz-On RC
  • AJAX
  • Mozilla Firefox
  • Powered by FeedBurner
  • AddThis Feed Button
Publicité
Copyright

© 2002 - 2017 - www.Gaz-On.net | Home | Contactez Sloq le Webmaster | Contactez Moumerico | Devenez Partenaire| Gaz-On RC recrute|

La version 4.0 de www.Gaz-On.net est compatible avec les navigateurs Internet Explorer 5.5 et ultérieures et avec toutes les versions de Mozilla Firefox.